NativeScript

Submit and vote on ideas for the NativeScript framework and NativeScript plugins

Support older Android versions

According to this:

http://www.telerik.com/support/whats-new/nativescript

Later releases will support older Android version - our target is Android 2.3 as well as latest API levels.

 

  • Gravatar starshine wang
  • Jul 17 2015
Link to GitHub issue https://github.com/NativeScript/NativeScript/issues/453
  • Attach files
  • Bradley Martin commented
    September 28, 2015 16:03

    Is this on the roadmap to work soon? It's a bit of a hang up for many people I know that need to support at least 4.1 Android. The company I work for has company devices, HTC One X from ATT and it's locked on 4.1, no update was made after that. It's only a 2 year old device. If that was the minimum version I think you'd satisfy many developers. 

  • Jun Matsushita commented
    November 19, 2015 11:35

    Also hoping to have an update on this! Thanks! Sorry for the cross-posting : https://github.com/NativeScript/NativeScript/issues/453#issuecomment-158030391

  • Adepitan Masud commented
    February 15, 2016 17:27

    Wud love if its  support older android versions ar least 4.1  as it still takes a significant percentage on android dashboard wit 8.8%. More developers wld cum to lik nativescript

  • Steven Stratis commented
    April 13, 2016 15:42

    Has there been any additional info released for this and when it can be expected? 

  • Calebe Aires commented
    May 4, 2016 18:48

    Mexico, Brazil, Argentina and others countries has almost 40% of active android devices running Android 4.0 to 4.3.

  • Shin K commented
    June 21, 2016 08:24

    Several millions devices in Thailand and South east asia still on 4.0/ 4.1. Official reports said currently as of 2016 more than 34% from overall are below 4.3

     

    Just a fact.

  • Valio Stoychev commented
    August 15, 2016 07:41

    There is work done in this regards - the current Android runtime already supports 2.3+, but we need to update the JavaScript cross-platform abstractions to not use 4.3+ API, but to use 4.1+.

     

    You can follow the progress in this issue - https://github.com/NativeScript/NativeScript/issues/694 

  • Valio Stoychev commented
    November 21, 2016 07:47

    Everyone, who is interested in supporting older Android versions - please check this pull request that bring us closed to API 16 (API 14 and 15 in progress too).

    https://github.com/NativeScript/NativeScript/issues/694#issuecomment-261820484 

  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar